Skocz do zawartości




Ciągle trwa jeszcze głosowanie w kolejnej edycji Złotych Szaraków! Kliknij tutaj i zagłosuj w tej jakże prestiżowej imprezie!


Zdjęcie

Windows 10 - problem z grafiką.


  • Zaloguj się, aby dodać odpowiedź
13 odpowiedzi w tym temacie

#1

Mariush.
  • Postów: 4077
  • Tematów: 59
  • Płeć:Mężczyzna
  • Artykułów: 5
Reputacja znakomita
Reputacja

Napisano

Mam pytanie do kogoś kto ma Windowsa 10 i/lub zna się na nim.

 

Coraz większe problemy z moim dotychczasowym, leciwym komputerem z XP-kiem na pokładzie spowodowały, że ostatnio zaopatrzyłem się w całkiem nowy sprzęt. Jako OS wybrałem Windowsa 10. Wiem, że system nie ma na razie zbyt pochlebnych recenzji (w związku m.in. z polityką prywatności Microsoftu), ale mnie akurat owe kwestie specjalnie nie przeszkadzają.

 

Niestety przeszkadza mi coś zupełnie innego.

Chodzi mi o jakość obrazu wyświetlanego na monitorze. W ustawieniu natywnym (FullHD 1920x1080) obraz jest nieco rozmyty. Czcionki, grafiki, wszystko jest nieostre. W XP-ku obraz był jak żyleta. Przykładowo linie tworzące litery czcionki Verdana, którą używam właśnie w forumowym edytorze miały dokładnie szerokość 1 piksela, co powodowało że tekst był bardzo wyraźny i czytelny. Nawet czcionki mniejsze niż 10 pt były wyraźnie generowane. A teraz to jest jakaś porażka. Litery o standardowej wielkości są rozjechane, co utrudnia czytanie, a mniejsze bywają czasem zupełnie nieczytelne. Inny przykład. Narysowanie w Paincie linii o 1-pikselowej grubości to teraz katorga dla wzroku. Wcześniej linia miała faktycznie 1 piksel szerokości, a teraz to szkoda gadać. W załączniku podaję obrazkowy przykład jak to wygląda w przypadku liter (w powiększeniu). U góry obraz tego, co było wcześniej, u dołu to, co jest teraz.

 

Poczytałem trochę na ten temat i dowiedziałem się, że przeskalowanie obrazu do ok. 125% polepsza czytelność (system nie robi tego najlepiej, więc użyłem programiku Windows 10 DPI Fix). Ale powiększenie wszystkiego to nie jest żadne rozwiązanie dla kogoś, komu zależy na przestrzeni roboczej monitora. Zresztą, może zabieg ten pomaga czcionkom, ale grafikom niestety wybitnie nie służy. Wzór fizyczny zapisany w postaci obrazu (np. png) wygląda jeszcze bardziej koszmarnie. Kupna monitora 4K (i odpowiedniej karty grafiki), co ewentualnie też mogłoby pomóc, nie biorę pod uwagę. ;)

 

Z tego co się orientuję, taki efekt to wynik odmiennej metody skalowania i wygładzania czcionek stosowanej przez MS w nowszych wersjach systemu. I tu mam pytanie: Czy można jakoś wymusić na systemie, aby skalował obraz po staremu?

Załączone grafiki

  • example.png




#2

Staniq.

    In principio erat Verbum.

  • Postów: 5168
  • Tematów: 684
  • Płeć:Mężczyzna
  • Artykułów: 23
Reputacja znakomita
Reputacja

Napisano

Wygląda na problem ze sterownikami. Zainstaluj SlimDrivers (darmowy), który wyszuka i zainstaluje wszystkie niezbędne stery, nawet takie, których zazwyczaj nigdy nie szukamy.

 

Link: TUTAJ





#3

pishor.

    sceptyczny zwolennik

  • Postów: 4740
  • Tematów: 275
  • Płeć:Mężczyzna
  • Artykułów: 16
Reputacja znakomita
Reputacja

Napisano

Potwierdzam - jest niezły. Skorzystałem z niego dzięki podpowiedzi Staniqa.

Uważałbym tylko na sterowniki magistrali szeregowej.

Ostatnio miałem nieprzyjemną przygodę (win7), bo Slim Drivers zabrał się za ich aktualizację, nie skończył jej - w efekcie czego padły mi wszystkie porty USB i trochę się napociłem, żeby odzyskać oryginalne sterowniki.

Zanim zabierzesz się za aktualizacje sterowników, sprawdziłbym jeszcze wbudowaną funkcję windowsa, czyli ClearType - być może jej włączenie pomoże w poprawieniu wyglądu czcionek i ogólnie - ich czytelności.





#4

Last Sicarius.

    Ostrzewtłumie

  • Postów: 1437
  • Tematów: 84
  • Płeć:Mężczyzna
  • Artykułów: 3
Reputacja znakomita
Reputacja

Napisano

Jak już zamierzacie robić aktualizację sterowników to polecam przed, zrobić punkt przywracania systemu, żeby w razie co, się nie bawić i po prostu wrócić do działającego stanu. Ostatnio tak miałem przy instalowanie sterowników do grafiki i niestety tylko to mnie uratowało. A nie pamiętam czy slimdrivers sam robi punkt przywracania.





#5

TechnikWiertnik.
  • Postów: 37
  • Tematów: 4
  • Płeć:Mężczyzna
Reputacja neutralna
Reputacja

Napisano

Z tego co się naczytałem o W10 to na razie doszedłem do wniosku, że lepiej  trzymać się od niego z daleka. Co chwila ktoś ma problem, jak nie z grafiką to z siecią (wuchta znajomych po aktualizacji szybko wracała do poprzedniego systemu, właśnie poprzez problemy z internetem - laptop nie znajdywał karty sieciowej, wyłączał się po wyszukaniu sieci itp.).
Tu są jakieś porady, co robić w Twojej sytuacji, nie wiem czy podążałeś za tymi wskazówkami LINK, chociaż jest to wynik wyszukiwania pierwszej strony z Google, więc pewnie masz to dawno za sobą. Jeśli nie pomaga, to chyba zostaje czekać na kolejne aktualizacje, może to naprawią. Osobiście wolę się męczyć z kafelkami w W8 niż potem się męczyć na dziurawym systemie.

 

@Staniq, gdyby Twój program zadziałał to byłby przełom w walce z rozmytym obrazem użytkowników "dziesiątki", jestem ciekaw efektów.



#6

D.K..

    Semper invicta

  • Postów: 2283
  • Tematów: 1798
  • Płeć:Kobieta
  • Artykułów: 16
Reputacja znakomita
Reputacja

Napisano

Z tego co się orientuję, taki efekt to wynik odmiennej metody skalowania i wygładzania czcionek stosowanej przez MS w nowszych wersjach systemu. I tu mam pytanie: Czy można jakoś wymusić na systemie, aby skalował obraz po staremu?

 

O ile wiem, można. Tutaj jest całkiem sensownie wyglądający artykuł na ten temat, proszę: https://technet.micr...y/dn528846.aspx

 

W dużym skrócie, ustawiłabym klucz HKCU\Control Panel\Desktop\Win8DpiScaling na 1 oraz poeksperymentowała z pozostałymi kluczami podanymi w tym artykule (nie wiem, jakiej używasz rozdzielczości), np. LogPixels oraz DpiScalingVer. Prawdopodobnie system i tak przywróci wartości domyślne po restarcie, więc jeśli uzyskasz jakąś poprawę, to będziesz musiał także  sobie przygotować skrypt zmieniający ustawienia przy każdym uruchomieniu.

 

Możesz jeszcze spróbować dostroić ustawienia wyświetlania czcionek typu ClearType -- choć wątpię, by to akurat w czymś Ci pomogło. Ale być może...?

 

Inna sprawa, że kilka 10-tek w życiu widziałam i we wszystkich przypadkach obraz jest ogólnie paskudny :)





#7

Staniq.

    In principio erat Verbum.

  • Postów: 5168
  • Tematów: 684
  • Płeć:Mężczyzna
  • Artykułów: 23
Reputacja znakomita
Reputacja

Napisano

Hmmm dziwię się, bo u mnie dwa kompy już latają na dziesiątce, a trzeci czeka w kolejce. Desktop i laptop nie mają tych problemów. Takie wyświetlanie czcionki występuje tylko na niektórych stronach.

 

Pishor@

Tobie się pewnie transfer skończył...





#8

pishor.

    sceptyczny zwolennik

  • Postów: 4740
  • Tematów: 275
  • Płeć:Mężczyzna
  • Artykułów: 16
Reputacja znakomita
Reputacja

Napisano

Pishor@

Tobie się pewnie transfer skończył...

Raczej nie, bo to była, któraś z kolei ale nie ostatnia aktualizacja. Przebiegała normalnie, tak jak wszystkie, skończyła się i wtedy pojawił się komunikat, że niektóre elementy nie mogły zostać zaktualizowane. Efekt - brak sterowników magistrali i niedziałające USB.

Później aktualizowałem jeszcze co najmniej cztery pozycje. W sumie, na kilkanaście aktualizacji w jednej sesji, tylko ta jedna się wysypała.

Wszystkie przed nią i wszystkie po niej przebiegły prawidłowo.





#9

Staniq.

    In principio erat Verbum.

  • Postów: 5168
  • Tematów: 684
  • Płeć:Mężczyzna
  • Artykułów: 23
Reputacja znakomita
Reputacja

Napisano

Może była sztachnięta paczka sterów. Ja tak kiedyś walczyłem z kartą graficzną Radeona. Przez miesiąc aktualizacja ściągała uszkodzony pakiet. Później komuś się zachciało i poprawili. Od tego czasu mam wstręt do grafiki Radka.





#10

Mariush.
  • Postów: 4077
  • Tematów: 59
  • Płeć:Mężczyzna
  • Artykułów: 5
Reputacja znakomita
Reputacja

Napisano

Dzięki za wszystkie odpowiedzi.

Nie wydaje mi się, żeby to była kwestia sterowników. System jest świeży, postawiony od zera. Na razie się wstrzymam z grzebaniem w nich.

 

Ale przyjrzałem się bliżej problemowi i już wiem na czym dokładnie polega.

W pionie wszystko jest OK. Krawędzie są ostre. Obraz rozmywa się tylko w poziomie. I dotyczy to całości wyświetlanego obrazu, nie tylko czcionek. Sedno sprawy przybliża dołączona grafika.

 

Nie wiedzieć czemu, czarna pionowa linia o grubości 1 piksela rozkłada się na ekranie po połowie na dwa piksele szerokości (każdy z nich jest w połowie wygaszony). Można powiedzieć, że rysowana linia centruje się między pikselami ekranu zamiast w pikselu. Gdyby można było w jakiś sposób owe centrowanie przesunąć (nie przeskalować) o pół piksela wszystko byłoby idealnie.

Załączone grafiki

  • DSC_0784.JPG




#11

Mariush.
  • Postów: 4077
  • Tematów: 59
  • Płeć:Mężczyzna
  • Artykułów: 5
Reputacja znakomita
Reputacja

Napisano

Problem rozwiązany :)

Coś mnie tknęło, żeby jeszcze raz wejść w ustawienia w menu monitora i powalczyć ponownie z autojustowaniem obrazu. Po pierwszej próbie rozmazało mi się jeszcze bardziej, po drugiej obraz mi uciekł o kilka cm w prawo. Na szczęście nie poddałem się i jeszcze kilka raz wykonałem auto i chyba za piątym czy szóstym wszystko w końcu ustawiło się jak należy. Obraz jest perfekcyjny!

 

Dowód poniżej.

Jeszcze raz dziękuję wszystkim za zainteresowanie. :)

Załączone grafiki

  • DSC_0786.JPG




#12

Staniq.

    In principio erat Verbum.

  • Postów: 5168
  • Tematów: 684
  • Płeć:Mężczyzna
  • Artykułów: 23
Reputacja znakomita
Reputacja

Napisano

:facepalm: Monitor CRT masz? Założyłem, że masz monitor LCD. Ja w innym desktopie mam auto Adjustment załączony i przedwczoraj tam właśnie robiłem upgrade do 10-tki. Żadnych rewelacji tego typu nie doświadczyłem, a monitor ten (należy do mojego syna) ma już jakieś 6 lat, więc nie jest pierwszej młodości.

No, ale człowiek się uczy całe życie, a i tak głupi umiera, nie?





#13

Mariush.
  • Postów: 4077
  • Tematów: 59
  • Płeć:Mężczyzna
  • Artykułów: 5
Reputacja znakomita
Reputacja

Napisano

Nie mam CRT-ka. Mam LCD, ale na kablu analogowym D-Sub.

Z tego co się orientuję, w takiej sytuacji autojustowanie nie zainicjuje się samo, ale trzeba je wymusić. Moim błędem było to, że za pierwszym razem zbyt szybko zrezygnowałem z ustawiania sądząc, że już lepiej nie będzie.





#14

Staniq.

    In principio erat Verbum.

  • Postów: 5168
  • Tematów: 684
  • Płeć:Mężczyzna
  • Artykułów: 23
Reputacja znakomita
Reputacja

Napisano

Tenże właśnie jest podłączony do tego desktopa

 

pol_pl_Kabel-przewod-VGA-D-SUB--726_4.jpg

fot/google

 

i nie ma żadnych problemów. Możliwe, że kiedyś przestawiałeś coś w ustawieniach i dlatego teraz było rozjechane. No ale skoro już po ptakach to i dobrze.







Użytkownicy przeglądający ten temat: 1

0 użytkowników, 1 gości oraz 0 użytkowników anonimowych

stat4u